Fonction recherche

Quelques conseils pour accompagner vos premiers pas sur francocube, ainsi que les annonces des administrateurs et modérateurs.
La charte du forum | Forum : Comment ça marche ? | Faire des cubes en 3D dans le forum
18 messages Page 1 sur 2
la-chose
Icône nationale
Messages : 6240
Enregistré le : sam. juin 28, 2008 1:08 am


Je ne sais pas si vous vous en êtes aperçu mais la fonction recherche marche très mal depuis peu. (Exemple: TPE ne donne aucun résultat alors qu'en regardant sur le forum j'ai trouvé 2 sujets dont le titre comportait "TPE" et encore plus dans les messages des membres).
Et au passage, avez-vous une idée de la date de la future mise à jour ou c'est pas pour tout de suite ? (du style la correction des applets, toussa...)
Arsonist
VIP au club des 1000
Messages : 1978
Enregistré le : mer. sept. 05, 2007 12:39 pm


Et tu trouveras plus de trucs en cherchant les TIPE.
Flyt
Scotché au forum
Messages : 328
Enregistré le : sam. août 22, 2009 12:00 am


T'as raison Arsonist, il te répond 1 sujet... D'ailleurs tu n'as qu'à chercher "fonction recherche" il ne te sort pas ce sujet

Ben ça va pas depuis les problèmes de mai, je crois...
auguste
Passe sa journée ici. Et dort ici, aussi
Messages : 851
Enregistré le : sam. août 29, 2009 2:15 pm


Je pense qu'il ne cherche pas sur la nouvelle adresse du forum et ne sort que les résultats du site ou les résultats en cache de l'ancien forum.
Spols
Le belge du Magic
Messages : 5184
Enregistré le : jeu. août 18, 2005 2:44 pm


Il faut laisser le temps à GOOGLE de visiter les nouveaux topics, ceux ci ne sont pas instantanément indexé. La fonction recherche du forum est plus précise et utilise même les nouveaux topics.

ET je pense pas qu'une recherche prennent en compte les recherche multi-orthographe (même si google en gère certaine)
Arsonist
VIP au club des 1000
Messages : 1978
Enregistré le : mer. sept. 05, 2007 12:39 pm


Abawi, si t'utilises la recherche par Google aussi.
J'me disais bien que ça avait marché pour moi lundi...
la-chose
Icône nationale
Messages : 6240
Enregistré le : sam. juin 28, 2008 1:08 am


J'ai utilisé la recherche Google et la recherche forum. Google ne donne rien et la recherche forum doit donner 14 résultats mais il manque quand même pas mal de posts.
Spols
Le belge du Magic
Messages : 5184
Enregistré le : jeu. août 18, 2005 2:44 pm


la recherche du forum me retourne 15 résultat sur TPE (probablement 16 après ce post) et je ne pense pas que d'autre post contiennent l'expression "tpe". Une recherche de n'importe quelle terme de tpe tipe retourne 43 résultats
Tatsuya
Le photographe du cube
Messages : 5169
Enregistré le : mer. mai 09, 2007 2:53 pm


Je pense, comme la chose, que la fonction recherche marche très mal en ce moment.
Quand je recherche des vieux sujets, je ne les trouve plus.
Spols
Le belge du Magic
Messages : 5184
Enregistré le : jeu. août 18, 2005 2:44 pm


La fonction google était effectivement encore paramètrer sur l'ancienne adresse, je viens de corriger.

La fonction recherche du forum indexe moins bien les anciens messages pour des raisons de place nécéssaire dans la base de données.

En résumé, pour des sujet récent, utiliser la fonction du forum, pour des sujets plus anciens, utiliser google.
Carugo
VIP au club des 1000
Messages : 1049
Enregistré le : dim. oct. 14, 2007 6:45 pm


Non mais elle est grosse la base de données ?
130 000 message, 2000 membres, vous mettez quoi d'autre dedans ?
Tatsuya
Le photographe du cube
Messages : 5169
Enregistré le : mer. mai 09, 2007 2:53 pm


Tatsuya a écrit :
Je pense, comme la chose, que la fonction recherche marche très mal en ce moment.
Quand je recherche des vieux sujets, je ne les trouve plus.
Je me suis trompé, je parlais du champ Google. J'ai toujours utilisé celui-là ...
deadalnix
Unix Cube
Messages : 7316
Enregistré le : sam. nov. 11, 2006 10:44 pm


Carugo a écrit :
Non mais elle est grosse la base de données ?
130 000 message, 2000 membres, vous mettez quoi d'autre dedans ?
Et tu crois que tu peut balancer un like '%blabla%' sur tous les messages du forum comme ça oO

Faut une vraie structure de donnée pour faire les recherches.
cyril
Helvète Underground
Messages : 3929
Enregistré le : jeu. juin 30, 2005 10:13 am


Il existe effectivement un décalage entre le temps où les messages sont postés et le moment où google les indexe. Typiquement de quelques jours pour les petits sites, 1-2 jours ici. Le tableau ci-dessous liste les URLs existantes et celles indexées (donc trouvables via le moteur google) : on tourne en gros à + de 80-90%, sachant que les trous sont principalement dans les anciens messages :
Image

Spols, le changement que tu as fait est bon pour retrouver les messages sur le sous-domaine forum.francocube.com, mais on perd les liens vers les pages principales du site. Je pense qu'on devrait mettre un bouton qui recherche sur les deux (type *.francocube.com). Je testerai si c'est possible, maintenant qu'il y a deux sous-domaines distincts.

Remarquez que google a maintenant trouvé ce sujet si vous recherchez "fonction recherche" :D
Carugo
VIP au club des 1000
Messages : 1049
Enregistré le : dim. oct. 14, 2007 6:45 pm


deadalnix a écrit :
Et tu crois que tu peut balancer un like '%blabla%' sur tous les messages du forum comme ça oO

Faut une vraie structure de donnée pour faire les recherches.
Bah explique moi, je suis pas archi

Je veux bien croire que la structure de la base est un peu compliquée, mais y'a pas non plus énormément de données non ?
18 messages Page 1 sur 2